Przeznaczenie programu e-Dokumenty

 Top Previous Next

Program e-Dokumenty funkcjonuje wyłącznie w integracji z modułami Aplikacji Ramzes.

Pozwala usprawnić pracę w zakresie tworzenia i wysyłania dokumentów podpisanych kwalifikowanym podpisem elektronicznym.

Wszystkie operacje związane z podpisywaniem, wysyłaniem i odbieraniem UPO są wykonywane z poziomu programu. Nie ma potrzeby wykorzystywania dodatkowego programu do składania podpisu.

Obsługa sprowadza się do wykorzystania funkcjonalności w stosunku do wybranych danych (np. deklaracji VAT) i zatwierdzenia decyzji przez podanie kodu PIN do karty kryptograficznej.

Uzytkownicy programu Ramzes–SuperAdmin mają możliwość przygotowania dokumentów, dla poszczególnych firm w Aplikacji Ramzes, a natępnie ich wspólnej wysyłki, co pozwala na jednoczesne podpisanie (jeden raz wprowadzany PIN) i wysłanie wielu dokumentów

Bez modułu e-Dokumenty można korzystać z deklaracji papierowych albo przepisywać ich zawartość do formularzy interaktywnych w formacie pdf, które po podpisaniu e-podpisem mogą być dalej przesyłane do systemu e-Deklaracje.

W chwili udostępnienia niniejszego podręcznika program pozwala na:

Ø Podpisywanie dokumentów związanych z podatkiem od towarów i usług (VAT):

· zgłoszenie rejestracyjne VAT-R,
· deklaracja VAT-7,
· deklaracja VAT-7K,
· deklaracja VAT-7D,
· informacji podsumowującej VAT-UE,
· informacji podsumowującej VAT-UEK.

Ø Deklaracji w programie Ramzes–Płace:

· deklaracja PIT-4R,
· deklaracja PIT-8AR,
· deklaracja PIT-8C,
· deklaracja PIT-11,
· deklaracja PIT-40,


Instalacja programu


Uruchomienie kreatora instalacji programu

Program e-Dokumenty udostępniany jest, podobnie jak Aplikacja Ramzes,
w formie kreatora instalacji:

W trakcie instalacji należy zaakceptować umowę licencyjną:

Następnie można zaznaczyć dodatkowe zadania związane stroną internetową www.ramzes.pl (ustawić jako stronę główna, dodać do Ulubionych):

Użcie W kolejnym oknie przycisku [image] 8 powoduje rozpoczęcie instalowania e-Dokumenty.

Po rozpoczęciu instalacji instalowane są składniki oprogramowania umożliwiającego składanie podpisu i wysyłanie podpisanych dokumentów.

W kolejnym etapie instalacji należy zainstalować certyfikat.

Oprogramowanie wymaga również by w systemie była zainstalowana Java.

Pomyślne ukończenie instalacji certyfikatu kończy pracę programu e-Dokumenty.


Instalacja certyfikatu

W kolejnym etapie instalacji należy zainstalować certyfikat.

Przed instalacją certfikatu prezentowane sa jego szczegóły. W tym wystawca oraz okres wazności.

Po wybraniu przycisku: uruchamiany jest kreator instalacji certyfikatu.

W trakcie instalacji certyfikatu można wskazać inną niż automatyczna, lokalizację magazynu certyfikatów.

Po zakończeniu importu certyfikacy pojawia sie stosowny komunikat:


Instalacja Javy

Oprogramowanie wymaga by w systemie była zainstalowana:

Jeśli Java nie jest zainstalowana albo jest zainstalowana w niższej wersji, to jest ona doinstalowywana.


Uruchomienie kreatora instalacji w sieci.

W przypadku użytkowania Aplikacja Ramzes w sieci lokalnej użycie modułu e-Dokumenty jest możliwe tylko na tych stanowiska, na których uruchomiono kreator instalacji.

Zalecane jest jednak zainstalowanie modułu e-Dokumenty na wszystkich stanowiskach roboczych. Pozwala to na uniknięcie sytuacji, że uruchomienie Aplikacja Ramzes dla danej firmy ze stanowiska roboczego będzie skutkować deaktywacją modułu e-Dokumenty i koniecznością jego ponownej aktywacji powodując mniejszy komfort pracy z Aplikacją Ramzes.


Uruchomienie programu


Uruchomienie programu

Program e-Dokumenty nie jest odrębnie uruchamiany. Pozwala on, po jego aktywacji w danej firmie, zwiększyć funkcjonalność aktywnych dla tej firmy programów, które umożliwiają korzystanie z podpisu elektronicznego.

Program nie jest udostępniany w wersji testowej.

Przed rozpoczęciem pracy z programem e-Dokumenty zalecane jest zapoznanie się z podręcznikiem użytkownika programu Ramzes–Administrator, gdzie znajdują się informacje użyteczne do prawidłowego zainstalowania Aplikacji Ramzes oraz wskazówki pomocne w ustawieniu parametrów programów. System przewiduje rozwiązania, które pozwalają na dostosowanie programu do specyfiki działalności i ustalonych w przedsiębiorstwie zasad.


Aktywacja i rejestracja programu dla pierwszej firmy

Aktywacji programu e-Dokumenty należy dokonać w programie Ramzes–Administrator.

Aby aktywować program w pierwszej firmie, niezbędna jest poprawna rejestracja programu.

W oknie tym należy wprowadzić kolejno dane dostarczone przez producenta oprogramowania, czyli:

Ø Hasło,
Ø Nazwę firmy, (w pole Właściciel)
Ø Nr licencji, (w pole Licencja Nr)
Ø Nr klienta, (w pole Nr w bazie)
Ø Wersję.

Uwaga

Dane rejestracyjne należy wprowadzać w sposób uważny zwracając uwagę na wielkość liter, odstępy, ilość znaków „/” itp.

Po zapisaniu danych rejestracyjnych wyświetlany jest komunikat o niepoprawności danych, jeżeli zostały wpisanie błędnie, lub potwierdzający rejestrację programu.

AD_nieprawidlowe dane rej

Po niepoprawnym wprowadzeniu danych pojawia się okno listą najczęsciej spotykanych powodów nieudanej rejestracji:

Po zakończonej sukcesem aktywacji programu pojawia się przy nim stosowny status: „AKTYWNY”:


Aktywacja programu dla kolejnych firm

Po aktywacji i rejestracji programu w jednej z firm można go aktywować w kolejnych firmach. Rejestracja jest czynnością jednorazową i nie ma potrzeby wprowadzania numerów rejestracyjnych przy aktywacji w kolejnych firmach.

W przypadku powtórnego wprowadzenia licencji (np. upgrade na kolejny rok) rejestracja programu nie wymaga wprowadzania nazwy firmy i numeru klienta.

Wystarczające jest wprowadzenie nowego hasła i zmiana w numerze licencji (pierwszy znak):


Programy ksiegowe

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programach wchodzących w skład Aplikacji Ramzes takich jak: Ramzes–Księgi Handlowe, Ramzes–PKPiR, Ramzes–Ryczałt.

Przycisk e-Deklaracji w oknach Ewidencji VAT w programach księgowych:


Konfiguracja

Przed wykorzystaniem funkcjonalności modułu e-Dokumenty należy go skonfigurować przechodząc w menu poszczególnego programu, wchodzącego w skład Aplikacji Ramzes, do E-deklaracji.

Ramzes–Księgi Handlowe

Ramzes–PKPiR

Ramzes–Ryczałt

Ramzes–Płace

Ramzes–SuperAdmin

Po wybraniu E-deklaracji udostępniane jest okno z wykazem dokumentów wysłanych, gotowych do wysłania oraz odebrania UPO (Urzędowego Poświadczenia Odbioru).

Przed skorzystaniem z funkcjonalności modułu e-Dokumenty należy skonfigurować skrypt odpowiadający za sposób pracy modułu.

Przed zapisaniem konfiguracji skryptu odpowiadającego za wysyłanie podpisanych plików należy wybrać posiadany podpis czyli wskazać Kwalifikowane Centrum Certyfikacji, które dostarczyło podpis elektroniczny.

Przy próbie zapisu bez wskazania posiadanego podpisu pojawia się stosowny komunikat:


Wybór Centrum Certyfikacji

Program umożliwia korzystanie z podpisów oferowanych przez trzy Centra Certyfikacji:

Funkcję głównego urzędu certyfikacji dla infrastruktury bezpiecznego podpisu elektronicznego w Polsce pełni Narodowe Centrum Certyfikacji

Na mocy ustawy o podpisie elektronicznym Minister Gospodarki i Pracy powierzył ją Narodowemu Bankowi Polskiemu. W tym powierzył mu prowadzenie rejestru kwalifikowanych podmiotów świadczących usługi certyfikacyjne, o którym mowa w art. 30 ust. 2 pkt 1 ustawy z dnia 18 września 2001 r. o podpisie elektronicznym.

W przypadku posiadania podpisu oferowanego przez Krajową Izbę Rozliczeniową należy wybrać Szafir-KIR.

Posiadacze podpisu oferowanego przez SIGILLUM - Polskie Centrum Certyfikacji Elektronicznej powołane przez Polska Wytwórnia Papierów Wartościowych S.A. wybierają Sigillum.

Posiadacze podpisu oferowanego przez CERTUM – Powszechne Centrum Certyfikacji obok wskazania Certum powinni dodatkowo dopasować nr biblioteki, która obsłuży posiadaną przez nich wersję.

..

Możliwe jest również użycie własnej biblioteki kryptograficznej

Po użyciu przycisku [image] 8 można wskazać lokalizację gdzie zapisana jest biblioteka kryptograficzna.

Wskazana lokalizacja jest zapisywana i używana podczas podpisywania e-Deklaracji.

Zapewnia, to że nie nastąpi konflikt pomiedzy biblioteką dostarczaną przez Ramzes Sp. z o.o. a biblioteką, która była dostarczona wraz z certyfikatem.


Wybór certyfikatów

Obok wyboru Centrum Certyfikacji należy wybrać typy certyfikatów jakie obsługiwać ma program oraz czy ma być udostępniany wybór certyfikatu.

Certyfikat kwalifikowany, to certyfikat spełniający wymagania ustawy o podpisie elektronicznym, wydany przez kwalifikowany podmiot świadczący usługi certyfikacyjne. Podpis elektroniczny weryfikowany za pomocą certyfikatu kwalifikowanego oraz złożony za pomocą bezpiecznego urządzenia do składania podpisu elektronicznego, jest równoważny podpisowi własnoręcznemu. Certyfikat kwalifikowany może być wydany jedynie osobie fizycznej.

Certyfikaty niekwalifikowane, często nazywane również zwykłymi lub komercyjnymi, służą do podpisywania i szyfrowania poczty elektronicznej i plików. Certyfikaty kwalifikowane mogą być wykorzystane jedynie do składania podpisów przez osoby fizyczne, podczas gdy certyfikaty niekwalifikowane mogą być również stosowane do szyfrowania informacji, autoryzacji urządzeń sieciowych oraz zestawiania bezpiecznych połączeń, np. SSL, IPSEC. W przypadku zwykłego certyfikatu ustawa o podpisie elektronicznym nie narzuca wymagań na sposób generowania i przechowywania klucza prywatnego oraz sposób generowania podpisu elektronicznego weryfikowanego takim certyfikatem (programowo, czy też z wykorzystaniem kart kryptograficznych).


Format podpisu

Ustawa o podpisie elektronicznym dopuszcza możliwość składania podpisu elektronicznego w jednym z dwóch formatów. Są to formaty:

· PKCS#7 (z możliwością znakowania czasem i podpisu wielokrotnego),

· XAdES (w wariantach XAdES-BES, XAdES-T, XAdES-C)

z opcją kontrasygnaty Hades.

Wysyłając e-Deklaracje należy wybrać format PKCS#7.

PKCS # 7 - Cryptographic Message Sysntax Standard, opisuje ogólną składnię danych, do których może być stosowana kryptografia, jak podpisy i koperty cyfrowe.

XAdES (XML Advanced Electronic Signatures) - format kwalifikowanego podpisu elektronicznego, promowany przez Unię Europejską oraz w Polsce przez MSWiA. XAdES jest rozwinięciem XML-DSig.

XAdES jest technologią opisującą budowę, sposób tworzenia oraz weryfikacji dokumentu będącego podpisem elektronicznym. Specyfikacja została stworzona przez European Telecommunications Standards Institute (ETSI) w odniesieniu do dyrektywy Unii Europejskiej określającej zasady użycia podpisu elektronicznego kwalifikowanego ("DIRECTIVE 1999/93/EC OF THE EUROPEAN PARLIAMENT AND OF THE COUNCIL of 13 December 1999 on a Community framework for electronic signatures"). ETSI definiuje kilka form XAdES'a, każdy kolejna forma jest rozwinięciem poprzedniej.

XAdES-BES (Basic Electronic Signature) - podstawowa forma rozwijająca XML-DSig o czas lokalny, miejsce, role osoby składającej podpis, ścieżkę certyfikacji, stemple czasowe na wybranych lub wszystkich referencjach oraz dodatkowe podpisy (podpis wielokrotny, kontrasygnaty).

W przeciwieństwie do realizowanego w warstwie binarnej PKCS#7, XAdES jest formatem dopasowanym do struktury dokumentu XML, pozwalającym podpisywać "warstwę" informacyjną niezależnie od formatu edycyjnego. Stosowanie podpisu w tej warstwie spełnia postulat interoperacyjności systemów, pozwalając stosować różne standardy przetwarzania informacji bez utraty integralności przekazu informacyjnego. Jednocześnie format XAdES rozwiązuje problem weryfikacji ważności podpisu w momencie jego złożenia.


Opóźnienie Javy i tryb testowy

W zależności od wydajności systemu można ustalić opóźnienie Javy:

. środowisko testowe

Po zaznaczeniu: Aplikacja może pracować w trybie testowym. Pozwala to sprawdzenie poprawności wysyłanych dokumentów przy użyciu bramki testowej udostępnionej przez Ministerstwo Finansów.

Uwaga

Środowisko testowe systemu e-Deklaracje nie jest przeznaczone do przetwarzania danych osobowych zgodnie z ustawą o ochronie danych osobowych
(Dz. U. z 2002 r., Nr 101, poz. 926, t.j., z późn. zm.).

W związku z powyższym do środowiska testowego należy przesyłać jedynie takie informacje, które nie są danymi osobowymi podlegającymi ochronie na podstawie ustawy o ochronie danych osobowych
(w szczególności art. 6). Wszystkie przesłane do systemu informacje będą traktowane jako dane nieprawdziwe (fikcyjne).


E-deklaracje


E-deklaracje

Dokumenty można wysyłać bezpośrednio z poziomu danej deklaracji zgodnie.

Jeśli dokument nie był wysyłany a jedynie przygotowany, to operację można rozpocząć z poziomu E-deklaracji:

Po wysłaniu pojawia się komunikat o zakończeniu komunikacji a w Opisie pojawia się status Wysłany.

Użytkownik programu Ramzes–SuperAdmin może przygotowć dokumenty, dla poszczególnych firm w Aplikacji Ramzes, a natępnie skorzystać ze wspólnej wysyłki wskazanych dokumentów. Pozwala to na jednoczesne podpisanie (jeden raz wprowadzany PIN) i wysłanie wielu dokumentów. W tym przypadku w oknie E-deklaracje wystepuje dodatkowa kolumna FIRMA z numerem firmy w Aplikacji Ramzes.


Nr referencyjny

Po wysłaniu dokumentu gdy w kolumnie Opis jest status Wysłany. Jest możliwe poznanie numeru referencyjnego.


Wydruk UPO

W Opcjach dostępna jest możliwość wydrukowania UPO:

Pozostałe opcje E-deklaracji pozwalają na deaktywację domyślnego filtrowania, co pozwala zobaczyć wszystkie, wcześniej tworzono w ramach E-deklaracji, dokumenty. Niepotrzebne wpisy mogą być usunięte.


Pełnomocnictwo

W Opcjach dostępna jest możliwość obsługi pełnomocnictw. Można ustanowiś prnomocnictwo czyli sporządzić druk UPL-1 jak i odwołać pelnomocnictwo (na druku OPL-1).

Po ustaleniu jaki podmiot udziela pełnomocnictwa naleźy go wskazać:

W kolejnym kroku naleźy dodać/poprawić wpis na liście pełnomocnictw albo wybrać odwołanie pelnomocnictwa.


Dodatkowe informacje

 Top Previous

Na stronie http://www.e-deklaracje.gov.pl/index.php?page=do_pobrania udostępniane są m.in.: Specyfikacje We-Wy przedstawiające zasady wymiany informacji pomiędzy systemem informatycznym e-Deklaracje a oprogramowaniem interfejsowym przeznaczonym do przekazywania dokumentów do systemu e-Deklaracje. Podobna specyfikacja jest dostępna dla środowiska testowego.


Dostępne deklaracje

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programach wchodzących w skład Aplikacji Ramzes.

Jęśli w danym kontekście jest możliwość skorzystania z funkcjonalności e-Dokumenty, to w ramach aktywnego okna dostępny jest przycisk:


Dostępne deklaracje i konfiiguracja


Modyfikacja modułu.

Moduł może być modyfikowany poprzez ponowną instalację z użyciem najnowszej wersji instalatora, która jest udostępniana na stronie internetowej www.ramzes.pl. Również modyfikacja Aplikacji Ramzes powoduje zaktualizowanie modułu e-Dokumenty. Od zakresu zmian zależy czy jest konieczne aktualizowanie stanowisk roboczych. Stosowne informacje są dostarczane podczas udostępniania modyfikacji oraz poprzez komunikaty w programie.


O programie i podręczniku


Ramzes–Płace

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programie Ramzes–Płace wchodzącego w skład Aplikacji Ramzes.

Przycisk e-Deklaracji w oknach deklaracji w programie Ramzes-Płace:


Tworzenie dokumentu do wysyłki

Utworzenie dokumentu do wysłania następuje po kliknięciu na ikonę e-Deklaracji.

Na oknie z Formularz deklaracji przed podpisem i wysyłką prezentowana jest treść dokumentu:

Tworzony jest dokument w formacie XML, który można wysłać bezpośrednio z poziomu danej deklaracji albo wyjść i wysłać z poziomu E-deklaracji .


Uwagi końcowe


Wysłanie dokumentu

Przed rozpoczęciem wysyłania dokumentu należy potwierdzić chęć wysłania.

Następnie tworzony jest dokument i sprawdzana jest konfiguracja.

Jeśli konfiguracja nie pozwala na poprawne podpisanie i wysłanie e-deklaracji, to pojawia się stosowny komunikat (np. brak javy) i operacja jest przerywana:

Jeśli dany formularz był już wykonany, to można zdecydować czy powinien zostać utworzony nowy formularz czy też ma być nadpisany istniejący.

Nie jest również możliwe ponowne wysyłanie dokumentu w niezmienionej formie jeśli był o wcześniej wysłany i otrzymano potwierdzenie jego odbioru.

Jeżeli dokument był wysłany, a zmieniła się jego treść, to należy potwierdzić chęć ponownego wysłania:

Użytkownik jest też dodatkowo informowany jeśli, zgodnie z ustawieniami w konfiguracji, wysyła dokument na serwer testowy.

Utworzony dokument podpisywany jest z użyciem certyfikatu. W zależności od ustawień konfiguracji może być konieczny wybór certyfikatu.

Anulowanie wyboru certyfikatu przerywa proces składania podpisu i wysyłki.

Po udanej weryfikacji uruchamiany jest komponent, który pozwala na składanie i weryfikację podpisów elektronicznych. Zapewnia on prezentację podpisanego dokumentu, złożenie podpisu oraz zachowanie wyniku:

Po prezentacji i wyborze czynności [image] następuje składanie podpisu elektronicznego pod dokumentem:

Złożenie podpisu wymaga wprowadzenia PIN dla klucza.

W przypadku podpisywania większej ilości dokumentów (np. w programie Ramzes–SuperAdmin) możliwe jest użycie PIN-u trwałego.

W zależnosci od potrzeb można ustalić ograniczenie wg czasu lub ilości operacji albo pozostawić bez ograniczeń.

W przypadku wprowadzenia niepoprawny PIN pojawia się komunikat i można go wprowadzić ponownie:

Po prawidłowym złożeniu podpisu i zachowaniu wyniku można zakończyć wysyłanie dokumentu.

Po zakończeniu operacji pokazywane jest podsumowanie:

Wysłany dokument widoczny w zestawieniu E-deklaracji:


Żądanie UPO

Dla dokumentów które w kolumnie Opis mają status Wysłany. Jest możliwe Żądanie UPO (Urzędowego Poświadczenia Odbioru).

Podczas pobierania UPO pojawia się komunikat przypominający, ze konfiguracja wskazuje na pobieranie z serwera testowego.

Po pobraniu UPO, w zależności od rezultatu opis określa czy dokument został przyjęty (status: Przyjęty) albo wskazuje na powód odrzucenia. Gdy ponownie wskazujemy dokument, przycisk Żądanie UPO jest nieaktywny.

Przykładowe Opisy i Statusy po żądaniu UPO:

Jeśli dokument nie został jeszcze przetworzony, to UPO nie zostanie przysłane i należy po pewnym czasie ponowić żądanie.

W przypadku odrzucenia dostępne są objaśnienia otrzymywane z systemu e-Deklaracje Ministerstwa Finansów:

W E-deklaracjach można podejrzeć wysyłany dokument (podpisany) jak i UPO w formacie XML: