Przeznaczenie programu e-Dokumenty

 Top Previous Next

Program e-Dokumenty funkcjonuje wyłącznie w integracji z modułami Aplikacji Ramzes.

Pozwala usprawnić pracę w zakresie tworzenia i wysyłania dokumentów podpisanych kwalifikowanym podpisem elektronicznym.

Wszystkie operacje związane z podpisywaniem, wysyłaniem i odbieraniem UPO są wykonywane z poziomu programu. Nie ma potrzeby wykorzystywania dodatkowego programu do składania podpisu.

Obsługa sprowadza się do wykorzystania funkcjonalności w stosunku do wybranych danych (np. deklaracji VAT) i zatwierdzenia decyzji przez podanie kodu PIN do karty kryptograficznej.

Użytkownicy programu Ramzes–SuperAdmin mają możliwość przygotowania dokumentów, dla poszczególnych firm w Aplikacji Ramzes, a następnie ich wspólnej wysyłki, co pozwala na jednoczesne podpisanie (jeden raz wprowadzany PIN) i wysłanie wielu dokumentów

Bez modułu e-Dokumenty można korzystać z deklaracji papierowych albo przepisywać ich zawartość do formularzy interaktywnych w formacie pdf, które po podpisaniu e-podpisem mogą być dalej przesyłane do systemu e-Deklaracje.

W chwili udostępnienia niniejszego podręcznika program pozwala m. in. na:

Ø Podpisywanie dokumentów związanych z podatkiem od towarów i usług (VAT):

· zgłoszenie rejestracyjne VAT-R,
· deklaracja JPK_V7M,
· deklaracja JPK_V7K,
· deklaracja VAT-7D,
· informacji podsumowującej VAT-UE,
· informacji podsumowującej VAT-UEK.

Ø Deklaracji w programie Ramzes–Płace:

· deklaracja PIT-4R,
· deklaracja PIT-8AR,
· deklaracja PIT-8C,
· deklaracja PIT-11,
· deklaracja PIT-40,

Ø Deklaracji rocznych w programach księgowych Ramzes-PKPiR, Ramzes-Ryczałt, Ramzes-KH:

· deklaracja PIT-36,
· deklaracja PIT-36L,
· deklaracja PIT-28,
· deklaracja PIT-37.


Instalacja programu


Uruchomienie kreatora instalacji programu

Program e-Dokumenty udostępniany jest, podobnie jak Aplikacja Ramzes,
w formie kreatora instalacji:

W trakcie instalacji należy zaakceptować umowę licencyjną:

Po akceptacji należy wskazać folder instalacji (folder programu Aplikacja Ramzes).

Następnie można zaznaczyć dodatkowe zadania związane stroną internetową www.ramzes.pl (ustawić jako stronę główną, dodać do Ulubionych):

W kolejnym oknie użycie przycisku [image] 8 powoduje rozpoczęcie instalowania e-Dokumenty.

Po rozpoczęciu instalacji instalowane są składniki oprogramowania umożliwiającego składanie podpisu i wysyłanie podpisanych dokumentów.

W starszych wersjach aplikacji na kolejnym etapie instalacji należało zainstalować certyfikat.

Oprogramowanie wymaga również by w systemie była zainstalowana Java.

Pomyślne ukończenie instalacji certyfikatu kończy pracę programu e-Dokumenty.


Instalacja certyfikatu

W starszych wersjach aplikacji na kolejnym etapie instalacji należało zainstalować certyfikat. Na moment tworzenia instrukcji nie jest to wymagane.

Przed instalacją certyfikatu prezentowane są jego szczegóły. W tym wystawca oraz okres ważności.

Po wybraniu przycisku: uruchamiany jest kreator instalacji certyfikatu. Aby nie instalować certyfikatu należy wybrać klawisz OK.

W trakcie instalacji certyfikatu można wskazać inną niż automatyczna, lokalizację magazynu certyfikatów.

W przypadku problemów może okaząć się konieczne wskazanie lokalizacji magazynu certyfikatów i wybór 'Zaufane główne urzedy certyfikaty'

Po zakończeniu importu certyfikatów pojawia się stosowny komunikat:


Instalacja Javy

Oprogramowanie wymaga by w systemie była zainstalowana:

Jeśli Java nie jest zainstalowana albo jest zainstalowana w niższej wersji, to jest ona doinstalowywana.


Uruchomienie kreatora instalacji w sieci.

W przypadku użytkowania Aplikacja Ramzes w sieci lokalnej użycie modułu e-Dokumenty jest możliwe tylko na tych stanowiska, na których uruchomiono kreator instalacji.

Zalecane jest jednak zainstalowanie modułu e-Dokumenty na wszystkich stanowiskach roboczych. Pozwala to na uniknięcie sytuacji, że uruchomienie Aplikacja Ramzes dla danej firmy ze stanowiska roboczego będzie skutkować deaktywacją modułu e-Dokumenty i koniecznością jego ponownej aktywacji powodując mniejszy komfort pracy z Aplikacją Ramzes.


Uruchomienie programu


Uruchomienie programu

Program e-Dokumenty nie jest odrębnie uruchamiany. Pozwala on, po jego aktywacji w danej firmie, zwiększyć funkcjonalność aktywnych dla tej firmy programów, które umożliwiają korzystanie z podpisu elektronicznego.

Program nie jest udostępniany w wersji testowej.

Przed rozpoczęciem pracy z programem e-Dokumenty zalecane jest zapoznanie się z podręcznikiem użytkownika programu Ramzes–Administrator, gdzie znajdują się informacje użyteczne do prawidłowego zainstalowania Aplikacji Ramzes oraz wskazówki pomocne w ustawieniu parametrów programów. System przewiduje rozwiązania, które pozwalają na dostosowanie programu do specyfiki działalności i ustalonych w przedsiębiorstwie zasad.


Aktywacja i rejestracja programu dla pierwszej firmy

Aktywacji programu e-Dokumenty należy dokonać w programie Ramzes–Administrator.

Aby aktywować program w pierwszej firmie, niezbędna jest poprawna rejestracja programu.

W oknie tym należy wprowadzić kolejno dane dostarczone przez producenta oprogramowania, czyli:

Ø Hasło,
Ø Nazwę firmy, (w pole Właściciel)
Ø Nr licencji, (w pole Licencja Nr)
Ø Nr klienta, (w pole Nr w bazie)
Ø Wersję.

Uwaga

Dane rejestracyjne należy wprowadzać w sposób uważny zwracając uwagę na wielkość liter, odstępy, ilość znaków „/” itp.

Po zapisaniu danych rejestracyjnych wyświetlany jest komunikat o niepoprawności danych, jeżeli zostały wpisanie błędnie, lub potwierdzający rejestrację programu.

AD_nieprawidlowe dane rej

Po niepoprawnym wprowadzeniu danych pojawia się okno listą najczęsciej spotykanych powodów nieudanej rejestracji:

Po zakończonej sukcesem aktywacji programu pojawia się przy nim stosowny status: „AKTYWNY”:


Aktywacja programu dla kolejnych firm

Po aktywacji i rejestracji programu w jednej z firm można go aktywować w kolejnych firmach. Rejestracja jest czynnością jednorazową (w danym roku) i nie ma potrzeby wprowadzania numerów rejestracyjnych przy aktywacji w kolejnych firmach.

W przypadku powtórnego wprowadzenia licencji (np. upgrade na kolejny rok) rejestracja programu nie wymaga wprowadzania nazwy firmy i numeru klienta.

Wystarczające jest wprowadzenie nowego hasła i zmiana w numerze licencji (pierwszy znak):


Programy ksiegowe

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programach wchodzących w skład Aplikacji Ramzes takich jak: Ramzes–Księgi Handlowe, Ramzes–PKPiR, Ramzes–Ryczałt.

Przycisk e-Deklaracji w oknach Ewidencji VAT w programach księgowych:


Konfiguracja

Przed wykorzystaniem funkcjonalności modułu e-Dokumenty należy go skonfigurować przechodząc w menu poszczególnego programu, wchodzącego w skład Aplikacji Ramzes, do E-deklaracji.

Ramzes–PKPiR

Ramzes–Ryczałt

Ramzes–Księgi Handlowe

Ramzes–Płace

Ramzes–SuperAdmin

Po wybraniu E-deklaracji udostępniane jest okno z wykazem dokumentów wysłanych, gotowych do wysłania oraz odebrania UPO (Urzędowego Poświadczenia Odbioru).

Przed skorzystaniem z funkcjonalności modułu e-Dokumenty należy skonfigurować skrypt odpowiadający za sposób pracy modułu.

Parametr Wersja użytych bibliotek SDK zmienia się wraz z kolejnymi aktualizacjami oprogramowania, co pozwala korzystać z nowych podpisów udostępnianych przez producentów.

Podpisywanie danymi autoryzującymi

Zaznaczenie opcji [ x ] Czy deklaracje podpisywać danymi autoryzującymi (Opcja dostępna z poziomu firmy.) Dotyczy deklaracji VAT oraz wybranych zeznań rocznych pozwala podpisywać wybrane zeznania i deklaracje JPK tzw. danymi autoryzującymi. W takim przypadku nie korzystamy z podpisu kwalifikowanego. Obecnie m. in. można w ten sposób podpisywać deklaracje JPK_V7M osób fizycznych prowadzących działalność gospodarczą (nie dotyczy Spółek).


Wybór Centrum Certyfikacji

Program umożliwia korzystanie z podpisów oferowanych przez wiele Centrów Certyfikacji:

Przed zapisaniem konfiguracji skryptu odpowiadającego za wysyłanie podpisanych plików należy wybrać posiadany podpis czyli wskazać Kwalifikowane Centrum Certyfikacji, które dostarczyło podpis elektroniczny, np.: Szafir KiR, Certum.

Po zainstalowaniu w systemie Windows oprogramowania do podpisu uzyskanego od producenta na liście dostępnych podpisów zobaczymy odpowiednią dotychczas niewidoczną opcję. W przypadku planowanego zakupu nowego podpisu elektronicznego prosimy o kontakt w celu potwierdzenia, że taki podpis już jest przez nasz program obsługiwany.

Wybranie opcji Własna biblioteka do podpisu pozwala (konieczne tylko w szczególnych przypadkach) wskazać plik (bibliotekę kryptograficzną) obsługującą podpisywanie dokumentów pochodzący z instalacji konkretnego podpisu w systemie.

Po użyciu przycisku [image] 8 można wskazać lokalizację gdzie zapisana jest biblioteka kryptograficzna.

Wskazana lokalizacja jest zapisywana i używana podczas podpisywania e-Deklaracji.


Wybór certyfikatów

Obok wyboru Centrum Certyfikacji należy wybrać typy certyfikatów jakie obsługiwać ma program oraz czy ma być udostępniany wybór certyfikatu.

Certyfikat kwalifikowany, to certyfikat spełniający wymagania ustawy o podpisie elektronicznym, wydany przez kwalifikowany podmiot świadczący usługi certyfikacyjne. Podpis elektroniczny weryfikowany za pomocą certyfikatu kwalifikowanego oraz złożony za pomocą bezpiecznego urządzenia do składania podpisu elektronicznego, jest równoważny podpisowi własnoręcznemu. Certyfikat kwalifikowany może być wydany jedynie osobie fizycznej.

Certyfikaty niekwalifikowane, często nazywane również zwykłymi lub komercyjnymi, służą do podpisywania i szyfrowania poczty elektronicznej i plików. Certyfikaty kwalifikowane mogą być wykorzystane jedynie do składania podpisów przez osoby fizyczne, podczas gdy certyfikaty niekwalifikowane mogą być również stosowane do szyfrowania informacji, autoryzacji urządzeń sieciowych oraz zestawiania bezpiecznych połączeń, np. SSL, IPSEC. W przypadku zwykłego certyfikatu ustawa o podpisie elektronicznym nie narzuca wymagań na sposób generowania i przechowywania klucza prywatnego oraz sposób generowania podpisu elektronicznego weryfikowanego takim certyfikatem (programowo, czy też z wykorzystaniem kart kryptograficznych).

Zaznaczenie opcji [x] Czy udostępnić wybór certyfikatu

pozwala wybierać jeden z kilku zapisanych na czytniku podpisów.


Format podpisu

Ustawa o podpisie elektronicznym dopuszcza możliwość składania podpisu elektronicznego w jednym z dwóch formatów. Są to formaty:

· PKCS#7 (z możliwością znakowania czasem i podpisu wielokrotnego),

· XAdES (w wariantach XAdES-BES, XAdES-T, XAdES-C)

z opcją kontrasygnaty Hades.

Wysyłając e-Deklaracje należy wybrać format PKCS#7.

PKCS # 7 - Cryptographic Message Sysntax Standard, opisuje ogólną składnię danych, do których może być stosowana kryptografia, jak podpisy i koperty cyfrowe.

XAdES (XML Advanced Electronic Signatures) - format kwalifikowanego podpisu elektronicznego, promowany przez Unię Europejską oraz w Polsce przez MSWiA. XAdES jest rozwinięciem XML-DSig.

XAdES jest technologią opisującą budowę, sposób tworzenia oraz weryfikacji dokumentu będącego podpisem elektronicznym. Specyfikacja została stworzona przez European Telecommunications Standards Institute (ETSI) w odniesieniu do dyrektywy Unii Europejskiej określającej zasady użycia podpisu elektronicznego kwalifikowanego ("DIRECTIVE 1999/93/EC OF THE EUROPEAN PARLIAMENT AND OF THE COUNCIL of 13 December 1999 on a Community framework for electronic signatures"). ETSI definiuje kilka form XAdES'a, każdy kolejna forma jest rozwinięciem poprzedniej.

XAdES-BES (Basic Electronic Signature) - podstawowa forma rozwijająca XML-DSig o czas lokalny, miejsce, role osoby składającej podpis, ścieżkę certyfikacji, stemple czasowe na wybranych lub wszystkich referencjach oraz dodatkowe podpisy (podpis wielokrotny, kontrasygnaty).

W przeciwieństwie do realizowanego w warstwie binarnej PKCS#7, XAdES jest formatem dopasowanym do struktury dokumentu XML, pozwalającym podpisywać "warstwę" informacyjną niezależnie od formatu edycyjnego. Stosowanie podpisu w tej warstwie spełnia postulat interoperacyjności systemów, pozwalając stosować różne standardy przetwarzania informacji bez utraty integralności przekazu informacyjnego. Jednocześnie format XAdES rozwiązuje problem weryfikacji ważności podpisu w momencie jego złożenia.


Java i tryb testowy

Tryb testowy

Opcja [ ] TEST - wysyłanie na bramkę testową nie powinna być zaznaczona, gdy wysyłamy deklaracje z rzeczywistymi danymi. Wysyłka na testową bramkę w Ministerstwie Finansów nie jest wypełnieniem obowiązków sprawozdawczych. Taka sytuacja jest traktowana przez urząd jako niezłożenie deklaracji.

Po zaznaczeniu:

Aplikacja może pracować w trybie testowym. Pozwala to na sprawdzenie poprawności wysyłanych dokumentów przy użyciu bramki testowej udostępnionej przez Ministerstwo Finansów.

Uwaga

Środowisko testowe systemu e-Deklaracje nie jest przeznaczone do przetwarzania danych osobowych zgodnie z ustawą o ochronie danych osobowych
(Dz. U. z 2002 r., Nr 101, poz. 926, t.j., z późn. zm.).

W związku z powyższym do środowiska testowego należy przesyłać jedynie takie informacje, które nie są danymi osobowymi podlegającymi ochronie na podstawie ustawy o ochronie danych osobowych (w szczególności art. 6). Wszystkie przesłane do systemu informacje będą traktowane jako dane nieprawdziwe (fikcyjne).

Wersja JAVY

Opcja [ ] Wersja JAVY x64 jest niezbędna do skonfigurowania dla uzyskania prawidłowej współpracy aplikacji Ramzes z aplikacją JAVA.

Jeżeli w systemie Windows posiadamy wersję 64 bit, to zaznaczamy opcję:

Jeżeli w systemie Windows posiadamy wersję 32 bit, to nie zaznaczamy opcji:

Poniżej przykład zidentyfikowania w Panelu sterowania systemu Windows 32 bit wersji programu JAVA.

Opcja [ ] TEST - wysyłanie na bramkę testową nie powinna być zaznaczona, gdy wysyłamy deklaracje z rzeczywistymi danymi. Wysyłka na testową bramkę w Ministerstwie Finansów nie jest wypełnieniem obowiązków sprawozdawczych. Taka sytuacja jest traktowana przez urząd jako niezłożenie deklaracji.

Opóźnienie JAVY

W zależności od wydajności systemu można ustalić opóźnienie Javy (zmiany w tym zakresie są konieczne niezwykle rzadko):

.


E-deklaracje


E-deklaracje

Dokumenty można wysyłać bezpośrednio z poziomu danej deklaracji a jeśli dokument nie był wysyłany a jedynie przygotowany, to operację można rozpocząć z poziomu E-deklaracji:

Po wysłaniu pojawia się komunikat o zakończeniu komunikacji a w Opisie pojawia się status Wysłany.

Użytkownik programu Ramzes–SuperAdmin może przygotowć dokumenty, dla poszczególnych firm w Aplikacji Ramzes, a natępnie skorzystać ze wspólnej wysyłki wskazanych dokumentów. Pozwala to na jednoczesne podpisanie (jeden raz wprowadzany PIN) i wysłanie wielu dokumentów. W tym przypadku w oknie E-deklaracje wystepuje dodatkowa kolumna FIRMA z numerem firmy w Aplikacji Ramzes.


Nr referencyjny

Po wysłaniu dokumentu gdy w kolumnie Opis jest status Wysłany. Jest możliwe poznanie numeru referencyjnego.


Wydruk UPO

W Opcjach dostępna jest możliwość wydrukowania UPO:

Pozostałe opcje E-deklaracji pozwalają na deaktywację domyślnego filtrowania, co pozwala zobaczyć wszystkie, wcześniej tworzono w ramach E-deklaracji, dokumenty. Niepotrzebne wpisy mogą być usunięte.


Pełnomocnictwo

W Opcjach dostępna jest możliwość obsługi pełnomocnictw (wyłącznie wypełnienie i wydruk).

Można ustanowić pełnomocnictwo, czyli sporządzić druk UPL-1 jak i odwołać pełnomocnictwo (na druku OPL-1).

Po ustaleniu jaki podmiot udziela pełnomocnictwa należy go wskazać:

W kolejnym kroku naleźy dodać/poprawić wpis na liście pełnomocnictw albo wybrać odwołanie pełnomocnictwa.


JPK

Użycie przycisku [image] 8

JPK Generuj Zestawienie

pozwala przejść do Ewidencji plików JPK:


Podgląd danych dla JPK_VAT

Poprzez użycie przycisku [image] 8 dla każdego JPK_VAT dostepny jest podgląd danych w formie graficznej:

Przedstawia kwoty wykazane w JPK dla poszczególnych pól deklaracji VAT. Zawartość pliku możnazobaczyć z użyciem przycisku [image] 8


wydruk kwot ujetych w JPK_VAT

Poprzez użycie przycisku [image] 8 dla kazdego JPK_VAT dostepny jest podgląd danych w formie wydruku:

Kwoty prezentowane są na wydruku z groszami - tak jak w pliku JPK_VAT. W poszczególnych pozycjach kwoty są sumowane. Z uwagi na zaokrąglenia na deklaracjach VAT, kwoty te mogą się nieznacznie różnić od kwot na deklaracji z uwagi na to, że kwoty na deklaracji wynikają także z sumowania już zaokrąglonych kwot.

Dobrą (zalecaną) praktyką jest porównywanie kwot na tym wydruku z kwotami na deklaracji VAT. Pozwala to na zidentyfikowanie różnic przed ich wysyłkami do MF.


Weryfikacja pliku JPK

Poprzez użycie w Ewidencji dokumentów JPK przycisku [image] 8 uruchamiany jest proces weryfikacji który jest tożsamy z weryfikacją uruchamianą z poziomu generacji JPK.

Jeśli plik jest już zweryfikowany, to ponowna weryfikacja nie jest dostępna a przycisk [image] jest nieaktywny.

Jeśli z jakiegoś powodu była by potrzeba weryfikowanie, to można taki plik zapisać ( [image] 8) a nastepnie zaimportować ( [image] 8).


Wyślij do Szefa KAS

Poprzez użycie przycisku [image] 8 , uruchamianego przy wyłączonym znaczniku [image] (ustawienie domyślne) rozpoczyna się wysyłka pliku JPK do Szefa Krajowej Administracji Skarbowej.

Podczas wysyłania niezbędne jest złożenie podpisu, przez uprawnioną (upoważnioną) osobę, przy pomocy ważnego certyfikatu kwalifikowanego.

W Aplikacji Ramzes wymaga zainstalowania oprogramowania od dostawcy certyfikatu oraz posiadania licencji na moduł e-Dokumenty oraz aktywowanie go w danej firmie.

Konfiguracja podpisu jest, analogiczna jak dla e-Deklaracji, dostępna w †Menu programu†Raporty†deklaracje†E-deklaracje poprzez porzez użycie przycisku [image] 8 menu Opcje†Konfiguracja.

Podczas wysyłania pliku JPK uruchamiany jest komponent do składania podpisu.

Jeśli w konfiguracji podpisu zaznaczono:

to otwierane jest okno:

i jeśli zostanie odczytany certyfikat, to aktywny jest przycisk SZAFIR keyPodpisz 8 którego użycie pozwala na złożenie podpisu kontynuację wysyłki.

Jeśli certyfikat nie zostanie odnaleziony, to przycisk SZAFIR keyPodpiszOFF 8 jest nieaktywny.

Wtedy należy użyć kolejno przycisków: SZAFIR keyPomin 8 SZAFIR keyDalej 8

SZAFIR PodsumowanieAnulowano 8

i powrócić do skonfigurowania podpisu na danym komputerze.

Jeśli Aplikacja Ramzes jest skonfigurowana w sposób umożliwiający podpisanie dokumentu (zostanie odczytany certyfikat i ustalona włściwa biblioteka kryptograficzna), to należy wprowadzić PIN:

SZAFIR PIN kAT

W przypadku podania nieprawidłowego PIN jest możliwość ponownego wprowadzenia:

SZAFIR zly PIN Po podaniu poprawnego PIN i ew. konfiguracji dot. trwałego PIN mozna użyć przycisku: SZAFIR keyAnuluj 8 .

Jeśli nie zostanie wprowadzony prawidłowy PIN, to użycie przycisku SZAFIR keyAnuluj 8 pozwala na przerwanie operacji wprowadzania PIN, po której pojawi się komunikt:

SZAFIR Blad podpisu

Na koniec po złożeniu podpisu (poprawnym albo nie) i użyciu przycisku SZAFIR keyZakoncz 8 pojawi się okno z podsumowaniem wysyłki:

Po złożeniu podpisu następuje komunikacja z bramką MF i Aplikacja otrzeymuje nr referencyjny oraz adres pod jakim ma być umieszczony plik JPK.

Na zakończenie następuje proces umieszczania pliku JPK na serwerze a po jego poprawny zakończeniu status wysyłki powinien uzyskać status 120 co jest równoznaczne z komunikatem:

JPK Po wyslaniu120

Wszelkie inne komunikaty oznaczają, że wysyłka z róznych wzgledów się nie powiodła. W takiej sytuacji (np. status 100) należy ponowić wysyłkę albo usunąć powód niepowodzenia.


wysyłka na bramke testową

Poprzez użycie przycisku [image] 8 uruchamianego przy włączonym znaczniku [image] (ustawienie domyślne: wyłaczony) rozpoczyna się wysyłka pliku JPK na bramke testową.

W stosunku do wysyłki na bramke produkcyjną taka wysyłka powoduje skutecznej wysyłki JPK do Szefa KAS i otrzymania UPO.

Dodatkowo pojawia się komunikat, który ostrzega, że wysyłka jest na bramkę testową:

W przypadku wysyłki na bramkę testową w statusie dokumentu wysłanego oraz po odebraniu UPO pojawi się dopisek "-test":

JPK Status wyslanyTestowy JPK Status PobranoUPOtestowy

Również na wydruku UPO będzie "Ministerstwo Finansów Test":


Pobierz status

Poprzez użycie przycisku [image] 8 można sprawdzić status przetwarzania wysłanego pliku JPK. Jesli trwa przetwarzanie, to będzie pojawiał się komunikat:

JPK Po wyslaniu120

Jeśli plik został zweryfikowany przez MF , to jeśłi wygenerowano UPO, to jest ono pobierane i mozna je od razu albo później wydrukować:

Jeśli podczas weryfikacji przesłany plik jest odrzucany to pojawia się stosowny komunikat o błędzie.

Powodem odrzucenia może być tak błąd w pliku (np. niepoprawny <CelZłożenia>) jak i problem z podpisem (np. brak ustanowionego pełnomocnictwa).


Wydruk UPO

Przycisk [image] 8 umożliwia wydrukowanie UPO dla plików dla których je pobrano.

Dla plików dla których nie odebrano UPO (np. nie wysłanych, odrzuconych) przycisku [image] jest nieaktywny.

Poprawne Urzędowe Poświadczenie Odbioru winno w części A zawierać napis "Ministerstwo Finansów" - bez żadnych dopisków:

JPK_VAT AT UPO 18m04


Import pliku JPK

Użycie przycisku [image] 8 umożliwia zaimportowanie wczytanie do bazy Aplikacji dowolnego pliku JPK przeznaczonego dla podmiotu który jest w danej firmie obsługiwany (weryfikowany jest NIP).

Pozwala to na wczytanie, weryfikację i wysyłkę pliku sporządzonego poza Aplikacją Ramzes. Umożliwia też zaimportowanie pliku poprawionego poza Aplikacją (np. w edytorzez zmieniono <CelZłożenia>).

Jest to także użyteczna metoda przy różnych przenoszeniach danych czy też interwencjach serwisu producenta Aplikacji Razmes.

Import należy rozpocząć od wskazania położenia importowanego pliku JPK:

Po wskazaniu folderu należy wskazać konkretny plik xml:

Wskazany plik JPK jest analizowany i prezentowane są dane z jego Nagłówka:

8

Importowany plik można zweryfikować bezpośrednio albo odłożyć weryfikację (możliwa z poziomu Zestawiania plikó JPK).

Weryfikacja jest analogiczna jak dla każdego pliku JPK.

Zaimportowany plik JPK jest dodawany do Ewidencji plików JPK:

Tak jak dla kazdego JPK_VAT dostepny jest podgląd danych w formie wyruku


Połącz pliki JPK

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Dzieki tej funkcji możliwe jest dołączanie do wskazanego pliku bazowego (pliku na którym jest kursow Zestawienia plików JPK)

innego pliku JPK_VAT uzyskanego z innego miejsca (inny program, inna firma itp.)

Używając tej funkcji trzeba mieć też na uwadze wymaganą zgodność (dopiszczalne różnice wynikające z zaokrągleń) pomiędzy plikiem JPK_VAT a deklaracją VAT.

Aby to umożliwić, to rejestry VAT w Aplikacji Ramzes pozwalają na wyłaczanie ich z procesu generowania pliku JPK na podstawie danych w Aplikacji Ramzes.

Wtedy kwoty wynikające z dołączanych plików JPK_VAT winny być wprowadzone do wydzielonych rejestrów (nie uwzględnianych w JPK_VAT generowanycm przez Aplikację), co pozwoli na uwzglednienie ich w deklaracji VAT-7 (VAT-7K).

Podczas łączenia plików JPK_VAT w pliku wynikowym uwzgledniany jest nagłówek z pliku bazowego ("z lewej strony") a dane plik dołączanego są doklejane na koniec pliku. Ponadto wyliczane są sumy kontrolne dla sprzedaży i zakupu, czyli sumowane są ilość wierszy sprzedaży i zakupu oraz kwoty podatków z obu plików.

W szczególności wynikowy CelZlożenia będzie z pliku bazowego. Czyli nie ma potrzeby tworzenie ponownie pliku zewnętrznego jeśli potrzebna jest wysyłka korekty JPK_VAT wynikająca z danych wprowadzanych do deklaracji.

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Poprzez użycie przycisku [image] 8 mozliwe jest łącznie plików JPK_VAT.

Po połaczeniu plików do Zestawienia plików JPK dodawany jest wpis z połączonym plikiem JPK_VAT. Na fakt połaczenie wskazuje jego Status (w kolejnych operacjach moze ulec zmianie) oraz wskaźnik w kolumnie Łączony, świadczący o tym, że plik został utworzony w wyniku połaczenia.

Poprzez użycie przycisku [image] 8 tak jak dla każdego pliku JPK_VAT dostępny jest, dla połączonego pliku, podgląd danych w formie wyruku.

Dla plików JPK_VAT powstałych w wyniku łaczenia takich plików dostępny jest przycisk:

8.

Użycie przycisku [image] 8 umożliwia dostęp do dołączonego pliku JPK_VAT:

Przycisk [image] 8 umożliwia weryfikację dołączonego pliku JPK_VAT.

Nie jest to operacja niezbędna dla skutecznej wysyłki, ponieważ wysyłany będzie plik połączony i to on przede wszystkim musi być zweryfikowany.

Jeśli jednak dołączane jest kolejno kilka plików JPK_VAT, to taka weryfikacja może być pomocna w ustalaniu źródła ewentualnych problemów.

Poprzez użycie przycisku [image] 8 tak jak dla każdego pliku JPK_VAT dostępny jest podgląd danych w formie wydruku:


Zapis pliku JPK na dysku

Przycisk [image] 8 umozliwia zapisanie na dysku wskazanego pliku XML.

Lokalizacja zapisywanych plików jest stała a zapis pliku jest potwierdzany komunikatem:

Zapisany plik można odnaleźć we wskazanej lokalizacji.

Funkcja ta jest użyteczna z uwagi na fakt, że generowane plik JPK zapisywane w podfolderze \FIRMA_X\WINP-DATA\JPK\ może zostać nadpisany przez kolejną generację pliku JPK za ten sam okres.

Przykładowo korekta JPK spowoduje takie nadpisanie ale zapis wysłanego pierwotnie pliku pozwoli na dostęp do jego treści.

Inne wykorzystanie to umożliwienie dostępu do treści po (skutecznej) weryfikacji pliku.


Uwagi dot. pliku JPK

Przycisk [image] 8 pozwala na dodanie krótkiej (do 50 znaków) uwagi dotyczącej pliku JPK.

Po użyciu przycisku [image] 8 wprowadzona uwaga pojawia się w polu na prawo od przycisku [image] 8 .


Kopiowanie numeru referencyjnego

Przycisk [image] 8 umożliwia skopiowanie do schowka nr referencyjnego. Może on być wykorzystany w kontaktach z Urzedami Skarbowymi ale także np. dla uzyskania UPO poprzez pdf interaktywny dostarczany przez Ministerstwo Finansów. Dla przykładu BR wysyła Klientowi Nr referencyjny w mailu co pozwala mu na pobranie UPO.


Usunięcie pliku JPK

Przycisk [image] 8 umożliwia usunięcie pliku JPK.

Usunięcie pliku wymaga dodatkowego potwierdzenia:

Dla plików wysłanych przycisk [image] 8 jest niedostępny.


Filtrowanie w ewidencji plików JPK

Przycisk [image] 8 pozwala na filtrowanie plików w Zestawieniu plików JPK.

Dostępne jest m.in. filtrowanie wg rodzaju oraz statusu pliku JPK:

Po użyciu przycisku [image] 8 w Ewidencji plików JPK widoczne są tylko pliki spełniające kryteria filtrowania:


Zestawienie wygenerowanych plików JPK

Poprzez użycie przycisku [image] 8 możliwe jest wydrukowanie zestawienia plików w Ewidencji plików JPK:


komunikaty Ministerstwa Finansów

Przycisk [image] 8 pozwala przejść do strony www dotyczacej JPK na portalu podatkowym (www.podatki.gov.pl).

Moze to być pomocne dla sprawdzenia czy nie ma np. przerwy w działaniu usługi. Nie ma przeszkód by zapoznać się także z innymi informacjami od MF.

Jeśli link przestanie działać w związku z reorganizacją stron MF, to zostanie on zmieniony w kolejnej modyfikacji Aplikacji.


Status JPK - przesłano duplikat

Status JPK o treści przesłano duplikat nie jest generowany przez aplikację Ramzes ale jest pobierany z serwera Ministerstwa Finansów i prezentowany w programie.

Taki status wynika z powielenia wysyłki pliku JPK. Powielenie wysyłki JPK jest możliwe w sytuacji nieprawidłowego działania serwera Ministerstwa Finansów, kiedy to serwer przyjmuje pliki ale nie odsyła potwierdzenia do nadawcy.

W efekcie w aplikacji Ramzes znajduje się wyłącznie numer referencyjny powielonej wysyłki a ten numer nie pozwala pobrać UPO ani poprzez nasz program ani bezpośrednio na stronie MF.

Na stronie https://e-mikrofirma.mf.gov.pl/jpk-client/Status istnieje możliwość sprawdzenia statusu wysyłki i uzyskania numeru referencyjnego pierwotnej wysyłki pliku JPK.

Kopiujemy numer referencyjny z aplikacji Ramzes

a następnie wklejamy ten numer we właściwe pole na stronie MF i klikamy Sprawdź.

Uzyskany numer referencyjny oryginalnej wysyłki kopiujemy ze strony MF.

A następnie wprowadzamy przy właściwym pliku JPK w aplikacji Ramzes. Używamy do tego przycisku nr ref. ręcznie.

Przy powyższych działaniach należy zwrócić uwagę aby w aplikacji powiązać numer referencyjny z właściwym plikiem JPK.

Powinniśmy otrzymać komunikat: Przetwarzanie dokumentu zakończone poprawnie. Wygenerowano UPO,

a następnie: Pobrano UPO. Wydrukować?

Pozwoli nam to wydrukować UPO do pierwotnej wysyłki pliku JPK.


Dodatkowe informacje

 Top Previous

Na stronie https://www.podatki.gov.pl/e-deklaracje oraz na stronie https://www.podatki.gov.pl/komunikaty-techniczne udostępniane są komunikaty dotyczące funkcjonowania systemu e-Deklaracje (w tym informacje o przerwach w dostępie do systemu).

Na stronie https://www.podatki.gov.pl/e-deklaracje/dokumentacja-it udostępniane są m.in.: Specyfikacje We-Wy przedstawiające zasady wymiany informacji pomiędzy systemem informatycznym e-Deklaracje a oprogramowaniem interfejsowym przeznaczonym do przekazywania dokumentów do systemu e-Deklaracje. Podobna specyfikacja jest dostępna dla środowiska testowego.


Dostępne deklaracje

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programach wchodzących w skład Aplikacji Ramzes.

Jęśli w danym kontekście jest możliwość skorzystania z funkcjonalności e-Dokumenty, to w ramach aktywnego okna dostępny jest przycisk:


Modyfikacja modułu.

Moduł może być modyfikowany poprzez ponowną instalację z użyciem najnowszej wersji instalatora, która jest udostępniana na stronie internetowej www.ramzes.pl. Również modyfikacja Aplikacji Ramzes powoduje zaktualizowanie modułu e-Dokumenty. Od zakresu zmian zależy czy jest konieczne aktualizowanie stanowisk roboczych. Stosowne informacje są dostarczane podczas udostępniania modyfikacji oraz poprzez komunikaty w programie.


O programie i podręczniku


Ramzes–Płace

Moduł e-Dokumenty umożliwia przygotowanie i wysłanie deklaracji w programie Ramzes–Płace wchodzącego w skład Aplikacji Ramzes.

Przycisk e-Deklaracji w oknach deklaracji w programie Ramzes-Płace:


Tworzenie dokumentu do wysyłki

Utworzenie dokumentu do wysłania następuje po kliknięciu na ikonę e-Deklaracji.

Na oknie z Formularz deklaracji przed podpisem i wysyłką prezentowana jest treść dokumentu:

Tworzony jest dokument w formacie XML, który można wysłać bezpośrednio z poziomu danej deklaracji albo wyjść i wysłać z poziomu E-deklaracji .


Wysłanie dokumentu

Przed rozpoczęciem wysyłania dokumentu należy potwierdzić chęć wysłania.

Następnie tworzony jest dokument i sprawdzana jest konfiguracja.

Jeśli konfiguracja nie pozwala na poprawne podpisanie i wysłanie e-deklaracji, to pojawia się stosowny komunikat (np. brak Javy) i operacja jest przerywana:

Jeśli dany formularz był już wykonany, to można zdecydować czy powinien zostać utworzony nowy formularz czy też ma być nadpisany istniejący.

Jeżeli dokument był wysłany, a zmieniła się jego treść, to należy potwierdzić chęć ponownego wysłania:

Użytkownik jest też dodatkowo informowany jeśli, zgodnie z ustawieniami w konfiguracji, wysyła dokument na serwer testowy.

Utworzony dokument podpisywany jest z użyciem certyfikatu. W zależności od ustawień konfiguracji może być konieczny wybór certyfikatu.

Anulowanie wyboru certyfikatu przerywa proces składania podpisu i wysyłki.

Po udanej weryfikacji uruchamiany jest komponent, który pozwala na składanie i weryfikację podpisów elektronicznych. Zapewnia on prezentację podpisanego dokumentu, złożenie podpisu oraz zachowanie wyniku:

Po prezentacji i wyborze czynności [image] następuje składanie podpisu elektronicznego pod dokumentem:

Złożenie podpisu wymaga wprowadzenia PIN dla klucza.

W przypadku podpisywania większej ilości dokumentów (np. w programie Ramzes–SuperAdmin) możliwe jest użycie PIN-u trwałego.

W zależnosci od potrzeb można ustalić ograniczenie wg czasu lub ilości operacji albo pozostawić bez ograniczeń.

W przypadku wprowadzenia niepoprawny PIN pojawia się komunikat i można go wprowadzić ponownie:

Po prawidłowym złożeniu podpisu i zachowaniu wyniku można zakończyć wysyłanie dokumentu.

Po zakończeniu operacji pokazywane jest podsumowanie:

Wysłany dokument widoczny w zestawieniu E-deklaracji:

Wysyłanie dokumentu podpisywanego danymi autoryzującymi

W przypadku podpisywania dokumentu danymi autoryzującymi (zgodnie z konfiguracją) po użyciu przycisku

powoduje pokazanie okna z danymi autoryzującymi, gdzie należy wprowadzić właściwą kwotę przychodu.


Żądanie UPO

Dla dokumentów które w kolumnie Opis mają status Wysłany. Jest możliwe Żądanie UPO (Urzędowego Poświadczenia Odbioru).

Podczas pobierania UPO pojawia się komunikat przypominający, ze konfiguracja wskazuje na pobieranie z serwera testowego.

Po pobraniu UPO, w zależności od rezultatu opis określa czy dokument został przyjęty (status: Przyjęty) albo wskazuje na powód odrzucenia. Gdy ponownie wskazujemy dokument, przycisk Żądanie UPO jest nieaktywny.

Przykładowe Opisy i Statusy po żądaniu UPO:

Jeśli dokument nie został jeszcze przetworzony, to UPO nie zostanie przysłane i należy po pewnym czasie ponowić żądanie.

W przypadku odrzucenia dostępne są objaśnienia otrzymywane z systemu e-Deklaracje Ministerstwa Finansów:

W E-deklaracjach można podejrzeć wysyłany dokument (podpisany) jak i UPO w formacie XML:

W związku z awariami bramki MF, możliwe jest ponowne pobranie UPO pomimo, że otrzymano już potwierdzenie jego odbioru. Nalezy wtedy zaakceptować komunikat: